cLinkObj AddByCoord Method CSi API ETABS 2015
Adds a new link object whose end points are at the specified coordinates.

Namespace: ETABS2015
Assembly: ETABS2015 (in ETABS2015.dll) Version: 15.0.0.0 (15.0.0.0)
Syntax

int AddByCoord(
	double XI,
	double YI,
	double ZI,
	double XJ,
	double YJ,
	double ZJ,
	ref string Name,
	bool IsSingleJoint = false,
	string PropName = "Default",
	string UserName = "",
	string CSys = "Global"
)

Parameters

XI
Type: OnlineSystem Double
The X coordinate of the I-End of the added link object in the coordinate system defined by the CSys item.
YI
Type: OnlineSystem Double
The Y coordinate of the I-End of the added link object in the coordinate system defined by the CSys item.
ZI
Type: OnlineSystem Double
The Z coordinate of the I-End of the added link object in the coordinate system defined by the CSys item.
XJ
Type: OnlineSystem Double
The X coordinate of the J-End of the added link object in the coordinate system defined by the CSys item.
YJ
Type: OnlineSystem Double
The Y coordinate of the J-End of the added link object in the coordinate system defined by the CSys item.
ZJ
Type: OnlineSystem Double
The Z coordinate of the J-End of the added link object in the coordinate system defined by the CSys item.
Name
Type: OnlineSystem String 
This is the name that the program ultimately assigns for the link object. If no UserName is specified, the program assigns a default name to the link object. If a UserName is specified and that name is not used for another link object, the UserName is assigned to the link object; otherwise a default name is assigned to the link object.
IsSingleJoint (Optional)
Type: OnlineSystem Boolean
This item is True if a one-joint link is added and False if a two-joint link is added.
PropName (Optional)
Type: OnlineSystem String
This is either Default or the name of a defined link property.

If it is Default the program assigns a default link property to the link object. If it is the name of a defined link property, that property is assigned to the link object

UserName (Optional)
Type: OnlineSystem String
CSys (Optional)
Type: OnlineSystem String
The name of the coordinate system in which the link object end point coordinates are defined.

Return Value

Returns zero if the link object is successfully added; otherwise it returns a nonzero value.
Remarks

One-joint links are not supported in ETABS.
Examples

See Also