cLinkObj Delete Method CSi API ETABS 2015
Deletes link objects.

Namespace: ETABS2015
Assembly: ETABS2015 (in ETABS2015.dll) Version: 15.0.0.0 (15.0.0.0)
Syntax

int Delete(
	string Name,
	eItemType ItemType = eItemType.Objects
)

Parameters

Name
Type: OnlineSystem String
The name of an existing link object or group, depending on the value of the ItemType item.
ItemType (Optional)
Type: ETABS2015 eItemType
This is one of the items in the eItemType enumeration.

If this item is Objects, the link object specified by the Name item is deleted.

If this item is Group, the all link objects in the group specified by the Name item are deleted.

If this item is SelectedObjects, all selected link objects are deleted, and the Name item is ignored.

Return Value

Returns zero if the link objects are successfully deleted; otherwise it returns a nonzero value.
Remarks

Examples

See Also