cPropArea SetShellDesign Method CSi API ETABS 2015
Assigns the design parameters for shell-type area properties.

Namespace: ETABS2015
Assembly: ETABS2015 (in ETABS2015.dll) Version: 15.0.0.0 (15.0.0.0)
Syntax

int SetShellDesign(
	string Name,
	string MatProp,
	int SteelLayoutOption,
	double DesignCoverTopDir1,
	double DesignCoverTopDir2,
	double DesignCoverBotDir1,
	double DesignCoverBotDir2
)

Parameters

Name
Type: OnlineSystem String
The name of an existing shell-type area property.
MatProp
Type: OnlineSystem String
The name of the material property for the area property.
SteelLayoutOption
Type: OnlineSystem Int32
This is 0, 1 or 2 indicating, the rebar layout option.
ValueLayout
0Default
1One layer
2Two layers
DesignCoverTopDir1
Type: OnlineSystem Double
The cover to the centroid of the top reinforcing steel running in the local 1 axis direction of the area object. [L]

This item applies only when SteelLayoutOption = 1 or 2.

DesignCoverTopDir2
Type: OnlineSystem Double
The cover to the centroid of the top reinforcing steel running in the local 2 axis direction of the area object. [L]

This item applies only when SteelLayoutOption = 1 or 2.

DesignCoverBotDir1
Type: OnlineSystem Double
The cover to the centroid of the bottom reinforcing steel running in the local 1 axis direction of the area object. [L]

This item applies only when SteelLayoutOption = 2.

DesignCoverBotDir2
Type: OnlineSystem Double
The cover to the centroid of the bottom reinforcing steel running in the local 2 axis direction of the area object. [L]

This item applies only when SteelLayoutOption = 2.

Return Value

Returns zero if the parameters are successfully assigned; otherwise it returns a nonzero value.
Remarks

Examples

See Also