Sets the pier label assignment of one or more area objects
Namespace: ETABS2015Assembly: ETABS2015 (in ETABS2015.dll) Version: 15.0.0.0 (15.0.0.0)
int SetPier(
string Name,
string PierName,
eItemType ItemType = eItemType.Objects
)
Function SetPier ( _
Name As String, _
PierName As String, _
Optional ItemType As eItemType = eItemType.Objects _
) As Integer
int SetPier(
String^ Name,
String^ PierName,
eItemType ItemType = eItemType::Objects
)
Parameters
- Name
- Type:
System String
The name of an existing area object or group, depending on the
value of the ItemType item.
- PierName
- Type:
System String
The name of the pier assignment, or "None", to unset any assignment
- ItemType (Optional)
- Type: ETABS2015 eItemType
This is one of the following items in the eItemType enumeration:
- Object = 0
- Group = 1
- SelectedObjects = 2
If this item is Objects, the assignment is made to the area object
specified by the Name item.
If this item is Group, the assignment is made to all area objects
in the group specified by the Name item.
If this item is SelectedObjects, assignment is made to all selected
area objects, and the Name item is ignored.
Return Value
Returns zero if the assignment is successful;
otherwise it returns a nonzero value.
Public Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
Dim PierName as String
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4, 12, 12, 4, 4, 24, 24)
ret = SapModel.PierLabel.SetPier("MyPier")
ret = SapModel.AreaObj.SetPier("3", "MyPier")
ret = SapModel.AreaObj.GetPier("3", PierName)
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
Public Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
Dim PierName as String
'create ETABS object
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
'start ETABS application
ret = EtabsObject.ApplicationStart()
'create SapModel object
SapModel = EtabsObject.SapModel
'initialize model
ret = SapModel.InitializeNewModel()
'create steel deck template model
ret = SapModel.File.NewSteelDeck(4, 12, 12, 4, 4, 24, 24)
'define new pier label
ret = SapModel.PierLabel.SetPier("MyPier")
'set assignment
ret = SapModel.AreaObj.SetPier("3", "MyPier")
'get assignment
ret = SapModel.AreaObj.GetPier("3", PierName)
'close ETABS
EtabsObject.ApplicationExit(False)
'clean up variables
SapModel = Nothing
EtabsObject = Nothing
End Sub