cPropArea SetShellLayer_1 Method CSi API ETABS 2015
Assigns the layer parameters for shell-type area properties

Namespace: ETABS2015
Assembly: ETABS2015 (in ETABS2015.dll) Version: 15.0.0.0 (15.0.0.0)
Syntax

int SetShellLayer_1(
	string Name,
	ref int NumberLayers,
	ref string[] LayerName,
	ref double[] Dist,
	ref double[] Thickness,
	ref int[] MyType,
	ref int[] NumIntegrationPts,
	ref string[] MatProp,
	ref double[] MatAng,
	ref int[] S11Type,
	ref int[] S22Type,
	ref int[] S12Type
)

Parameters

Name
Type: OnlineSystem String
The name of an existing shell-type area property that is specified to be a layered shell property.
NumberLayers
Type: OnlineSystem Int32 
The number of layers in the area property.
LayerName
Type:  OnlineSystem String  
This is an array that includes the name of each layer.
Dist
Type:  OnlineSystem Double  
Thickness
Type:  OnlineSystem Double  
This is an array that includes the thickness of each layer. [L]
MyType
Type:  OnlineSystem Int32  
This is an array that includes 1, 2 or 3, indicating the layer type.
ValueType
1Shell
2Membrane
3Plate
NumIntegrationPts
Type:  OnlineSystem Int32  
The number of integration points in the thickness direction for the layer. The locations are determined by the program using standard Guass-quadrature rules.
MatProp
Type:  OnlineSystem String  
This is an array that includes the name of the material property for the layer.
MatAng
Type:  OnlineSystem Double  
S11Type
Type:  OnlineSystem Int32  
This is an array that includes 0, 1 or 2, indicating the material component behavior.
ValueS11Type
0Inactive
1Linear
2Nonlinear
S22Type
Type:  OnlineSystem Int32  
This is an array that includes 0, 1 or 2, indicating the material component behavior.
ValueS22Type
0Inactive
1Linear
2Nonlinear
S12Type
Type:  OnlineSystem Int32  
This is an array that includes 0, 1 or 2, indicating the material component behavior.
ValueS12Type
0Inactive
1Linear
2Nonlinear

Return Value

Returns zero if the parameters are successfully assigned; otherwise it returns a nonzero value.

The function returns an error if the specified area property is not a shell-type property specified to be a layered shell.

Remarks

Examples

See Also