cAreaObj GetRebarDataSpandrel Method CSi API ETABS 2015
Retrieves rebar data for an area spandrel object

Namespace: ETABS2015
Assembly: ETABS2015 (in ETABS2015.dll) Version: 15.0.0.0 (15.0.0.0)
Syntax

int GetRebarDataSpandrel(
	string Name,
	ref int NumberRebarLayers,
	ref string[] LayerID,
	ref eWallSpandrelRebarLayerType[] LayerType,
	ref double[] ClearCover,
	ref int[] BarSizeIndex,
	ref double[] BarArea,
	ref double[] BarSpacing,
	ref int[] NumberBars,
	ref bool[] Confined
)

Parameters

Name
Type: OnlineSystem String
The name of an existing area object
NumberRebarLayers
Type: OnlineSystem Int32 
LayerID
Type:  OnlineSystem String  
LayerType
Type:  ETABS2015 eWallSpandrelRebarLayerType  
ClearCover
Type:  OnlineSystem Double  
BarSizeIndex
Type:  OnlineSystem Int32  
BarArea
Type:  OnlineSystem Double  
BarSpacing
Type:  OnlineSystem Double  
NumberBars
Type:  OnlineSystem Int32  
Confined
Type:  OnlineSystem Boolean  

Return Value

Remarks

See Also