Assigns uniform loads to area objects.
Namespace: ETABS2015Assembly: ETABS2015 (in ETABS2015.dll) Version: 15.0.0.0 (15.0.0.0)
int SetLoadUniform(
string Name,
string LoadPat,
double Value,
int Dir,
bool Replace = true,
string CSys = "Global",
eItemType ItemType = eItemType.Objects
)
Function SetLoadUniform ( _
Name As String, _
LoadPat As String, _
Value As Double, _
Dir As Integer, _
Optional Replace As Boolean = True, _
Optional CSys As String = "Global", _
Optional ItemType As eItemType = eItemType.Objects _
) As Integer
int SetLoadUniform(
String^ Name,
String^ LoadPat,
double Value,
int Dir,
bool Replace = true,
String^ CSys = L"Global",
eItemType ItemType = eItemType::Objects
)
Parameters
- Name
- Type:
System String
The name of an existing area object or group, depending on the value
of the ItemType item.
- LoadPat
- Type:
System String
The name of a defined load pattern.
- Value
- Type:
System Double
The uniform load value. [F/L2]
- Dir
- Type:
System Int32
- Replace (Optional)
- Type:
System Boolean
If this item is True, all previous uniform loads, if any, assigned to the
specified area object(s), in the specified load pattern, are deleted before
making the new assignment.
- CSys (Optional)
- Type:
System String
This is Local or the name of a defined coordinate system, indicating the
coordinate system in which the uniform load is specified.
- ItemType (Optional)
- Type: ETABS2015 eItemType
This is one of the following items in the eItemType enumeration:
- Object = 0
- Group = 1
- SelectedObjects = 2
If this item is Objects, the assignment is made to the area object
specified by the Name item.
If this item is Group, the assignment is made to all area objects
in the group specified by the Name item.
If this item is SelectedObjects, assignment is made to all selected
area objects, and the Name item is ignored.
Return Value
Returns zero if the loads are successfully assigned;
otherwise it returns a nonzero value.
Public Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4, 12, 12, 4, 4, 24, 24)
ret = SapModel.AreaObj.SetLoadUniform("ALL", "DEAD", -0.01, 2, False, "Local", ETABS2013.eItemType.Group)
ret = SapModel.View.RefreshView(0, False)
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
Public Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
'create ETABS object
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
'start ETABS application
ret = EtabsObject.ApplicationStart()
'create SapModel object
SapModel = EtabsObject.SapModel
'initialize model
ret = SapModel.InitializeNewModel()
'create steel deck template model
ret = SapModel.File.NewSteelDeck(4, 12, 12, 4, 4, 24, 24)
'assign area object uniform loads
ret = SapModel.AreaObj.SetLoadUniform("ALL", "DEAD", -0.01, 2, False, "Local", ETABS2013.eItemType.Group)
'refresh view
ret = SapModel.View.RefreshView(0, False)
'close ETABS
EtabsObject.ApplicationExit(False)
'clean up variables
SapModel = Nothing
EtabsObject = Nothing
End Sub