Assigns a link property to link objects.
Namespace: ETABS2015Assembly: ETABS2015 (in ETABS2015.dll) Version: 15.0.0.0 (15.0.0.0)
int SetProperty(
string Name,
string PropName,
eItemType ItemType = eItemType.Objects
)
Function SetProperty ( _
Name As String, _
PropName As String, _
Optional ItemType As eItemType = eItemType.Objects _
) As Integer
int SetProperty(
String^ Name,
String^ PropName,
eItemType ItemType = eItemType::Objects
)
Parameters
- Name
- Type:
System String
The name of an existing link object or group,
depending on the value of the ItemType item.
- PropName
- Type:
System String
This is the name of a link property to be assigned
to the specified link object(s).
- ItemType (Optional)
- Type: ETABS2015 eItemType
This is one of the items in the eItemType enumeration.
If this item is Objects, the assignment is made to
the link object specified by the Name item.
If this item is Group, the assignment is made to
all link objects in the group specified by the Name item.
If this item is SelectedObjects, the assignment is made to
all selected link objects, and the Name item is ignored.
Return Value
Returns zero if the property is successfully assigned;
otherwise it returns a nonzero value.
Public Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
Dim Name As String
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)
ret = SapModel.LinkObj.AddByPoint("1", "5", Name)
ret = SapModel.LinkObj.SetProperty(Name, "Link1")
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
Public Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
Dim Name As String
'create ETABS object
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
'start ETABS application
ret = EtabsObject.ApplicationStart()
'create SapModel object
SapModel = EtabsObject.SapModel
'initialize model
ret = SapModel.InitializeNewModel()
'create steel deck template model
ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)
'add link object by points
ret = SapModel.LinkObj.AddByPoint("1", "5", Name)
'set link property
ret = SapModel.LinkObj.SetProperty(Name, "Link1")
'close ETABS
EtabsObject.ApplicationExit(False)
'clean up variables
SapModel = Nothing
EtabsObject = Nothing
End Sub