cFrameObj SetEndLengthOffset Method CSi API ETABS 2015
Assigns frame object end offsets along the 1-axis of the object.

Namespace: ETABS2015
Assembly: ETABS2015 (in ETABS2015.dll) Version: 15.0.0.0 (15.0.0.0)
Syntax

int SetEndLengthOffset(
	string Name,
	bool AutoOffset,
	double Length1,
	double Length2,
	double RZ,
	eItemType ItemType = eItemType.Objects
)

Parameters

Name
Type: OnlineSystem String
The name of an existing frame object or group, depending on the value of the ItemType item.
AutoOffset
Type: OnlineSystem Boolean
If this item is True, the end length offsets are automatically determined by the program from object connectivity, and the length1, length2 and rz items are ignored.
Length1
Type: OnlineSystem Double
Length2
Type: OnlineSystem Double
RZ
Type: OnlineSystem Double
The rigid zone factor. This is the fraction of the end offset length assumed to be rigid for bending and shear deformations.
ItemType (Optional)
Type: ETABS2015 eItemType
This is one of the following items in the eItemType enumeration:
  • Object = 0
  • Group = 1
  • SelectedObjects = 2

If this item is Objects, the assignment is made to the frame object specified by the Name item.

If this item is Group, the assignment is made to all frame objects in the group specified by the Name item.

If this item is SelectedObjects, the assignment is made to all selected frame objects and the Name item is ignored.

Return Value

Returns zero if the offsets are successfully assigned, otherwise it returns a nonzero value.
Remarks

Examples

See Also