Retrieves the names of the point objects at each end of a specified link object.
If names of the two point objects are the same, the specified link object is a one-joint link object.
Namespace: ETABS2015Assembly: ETABS2015 (in ETABS2015.dll) Version: 15.0.0.0 (15.0.0.0)
int GetPoints(
string Name,
ref string Point1,
ref string Point2
)
Function GetPoints ( _
Name As String, _
ByRef Point1 As String, _
ByRef Point2 As String _
) As Integer
int GetPoints(
String^ Name,
String^% Point1,
String^% Point2
)
Parameters
- Name
- Type:
System String
The name of a defined link object.
- Point1
- Type:
System String
The name of the point object at the I-End of the specified link object.
- Point2
- Type:
System String
The name of the point object at the J-End of the specified link object.
Return Value
Returns zero if the point names are successfully retrieved;
otherwise it returns a nonzero value.
Public Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
Dim Name As String
Dim Point1 As String
Dim Point2 As String
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)
ret = SapModel.LinkObj.AddByPoint("1", "5", Name)
ret = SapModel.LinkObj.GetPoints(Name, Point1, Point2)
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
Public Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
Dim Name As String
Dim Point1 As String
Dim Point2 As String
'create ETABS object
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
'start ETABS application
ret = EtabsObject.ApplicationStart()
'create SapModel object
SapModel = EtabsObject.SapModel
'initialize model
ret = SapModel.InitializeNewModel()
'create steel deck template model
ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)
'add link object by points
ret = SapModel.LinkObj.AddByPoint("1", "5", Name)
'get names of points
ret = SapModel.LinkObj.GetPoints(Name, Point1, Point2)
'close ETABS
EtabsObject.ApplicationExit(False)
'clean up variables
SapModel = Nothing
EtabsObject = Nothing
End Sub