Retrieves the uniform to frame load assignments to area objects.
Namespace: ETABS2015Assembly: ETABS2015 (in ETABS2015.dll) Version: 15.0.0.0 (15.0.0.0)
Syntax
Parameters
- Name
- Type:
System String
The name of an existing area object or group, depending on the value of the ItemType item.
- NumberItems
- Type:
System Int32
The total number of uniform to frame loads retrieved for the specified area objects.
- AreaName
- Type:
System String
This is an array that includes the name of the area object associated with each uniform to frame load.
- LoadPat
- Type:
System String
This is an array that includes the name of the load pattern associated with each uniform to frame load.
- CSys
- Type:
System String
This is an array that includes the name of the coordinate system associated with each uniform to frame load.
- Dir
- Type:
System Int32
- Value
- Type:
System Double
The uniform load value. [F/L^2]
- DistType
- Type:
System Int32
This is either 1 or 2, indicating the load distribution type.
- ItemType (Optional)
- Type: ETABS2015 eItemType
This is one of the following items in the eItemType enumeration:- Object = 0
- Group = 1
- SelectedObjects = 2
If this item is Objects, the assignments are retrieved for the area object specified by the Name item.
If this item is Group, the assignments are retrieved for all area objects in the group specified by the Name item.
If this item is SelectedObjects, assignments are retrieved for is made to all selected area objects, and the Name item is ignored.
Return Value
Returns zero if the load assignments are successfully retrieved; otherwise it returns a nonzero value.Remarks
See Also