Retrieves the frame local axis angle assignment for frame objects.
Namespace: ETABS2015Assembly: ETABS2015 (in ETABS2015.dll) Version: 15.0.0.0 (15.0.0.0)
int GetLocalAxes(
string Name,
ref double Ang,
ref bool Advanced
)
Function GetLocalAxes ( _
Name As String, _
ByRef Ang As Double, _
ByRef Advanced As Boolean _
) As Integer
int GetLocalAxes(
String^ Name,
double% Ang,
bool% Advanced
)
Parameters
- Name
- Type:
System String
The name of an existing frame object.
- Ang
- Type:
System Double
This is the angle that the local 2 and 3 axes are rotated about the
positive local 1 axis, from the default orientation or,
if the Advanced item is True, from the orientation determined by
the plane reference vector. The rotation for a positive angle appears
counter clockwise when the local +1 axis is pointing toward you. [deg]
- Advanced
- Type:
System Boolean
This item is True if the line object local axes orientation was
obtained using advanced local axes parameters.
Return Value
Returns zero if the assignment is successfully retrieved,
otherwise it returns a nonzero value.
Public Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4, 12, 12, 4, 4, 24, 24)
ret = SapModel.FrameObj.GetLocalAxes("3", Ang, Advanced)
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
Public Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
'create ETABS object
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
'start ETABS application
ret = EtabsObject.ApplicationStart()
'create SapModel object
SapModel = EtabsObject.SapModel
'initialize model
ret = SapModel.InitializeNewModel()
'create steel deck template model
ret = SapModel.File.NewSteelDeck(4, 12, 12, 4, 4, 24, 24)
'get frame local axis angle
ret = SapModel.FrameObj.GetLocalAxes("3", Ang, Advanced)
'close ETABS
EtabsObject.ApplicationExit(False)
'clean up variables
SapModel = Nothing
EtabsObject = Nothing
End Sub