cPropFrame GetTube Method CSi API ETABS 2015
Retrieves frame section property data for a tube-type frame section.

Namespace: ETABS2015
Assembly: ETABS2015 (in ETABS2015.dll) Version: 15.0.0.0 (15.0.0.0)
Syntax

int GetTube(
	string Name,
	ref string FileName,
	ref string MatProp,
	ref double T3,
	ref double T2,
	ref double Tf,
	ref double Tw,
	ref int Color,
	ref string Notes,
	ref string GUID
)

Parameters

Name
Type: OnlineSystem String
The name of an existing frame section property.
FileName
Type: OnlineSystem String 
If the section property was imported from a property file, this is the name of that file. If the section property was not imported, this item is blank.
MatProp
Type: OnlineSystem String 
The name of the material property for the section.
T3
Type: OnlineSystem Double 
T2
Type: OnlineSystem Double 
Tf
Type: OnlineSystem Double 
Tw
Type: OnlineSystem Double 
Color
Type: OnlineSystem Int32 
Notes
Type: OnlineSystem String 
GUID
Type: OnlineSystem String 
The GUID (global unique identifier), if any, assigned to the section.

Return Value

Returns zero if the section property data is successfully retrieved; otherwise it returns a nonzero value.
Remarks

Examples

See Also