Assembly: ETABS2015 (in ETABS2015.dll) Version: 15.0.0.0 (15.0.0.0)
int GetTCFrictionIsolator( string Name, ref bool[] DOF, ref bool[] Fixed, ref bool[] Nonlinear, ref double[] Ke, ref double[] Ce, ref double[] K, ref double[] Slow, ref double[] Fast, ref double[] Rate, ref double[] Radius, ref double[] SlowT, ref double[] FastT, ref double[] RateT, ref double Kt, ref double Dis, ref double Dist, ref double Damping, ref double DJ2, ref double DJ3, ref string Notes, ref string GUID )
Parameters
- Name
- Type:
System String
The name of an existing T/C friction isolator-type link property.
- DOF
- Type:
System Boolean
- Fixed
- Type:
System Boolean
This is a boolean array, dimensioned to 5, indicating if the specified degree of freedom is fixed (restrained).Value Fixity Fixed(0) U1 fixity if DOF(0) = True Fixed(1) U2 fixity if DOF(1) = True Fixed(2) U3 fixity if DOF(2) = True Fixed(3) R1 fixity if DOF(3) = True Fixed(4) R2 fixity if DOF(4) = True Fixed(5) R3 fixity if DOF(5) = True
- Nonlinear
- Type:
System Boolean
This is a boolean array, dimensioned to 5, indicating if nonlinear properties exist for a specified degree of freedom.Value Nonlinear Nonlinear(0) U1 has nonlinear properties Nonlinear(1) U2 has nonlinear properties Nonlinear(2) U3 has nonlinear properties Nonlinear(3) R1, not used Nonlinear(4) R2, not used Nonlinear(5) R3, not used Note that this item is applicable only for degrees of freedom U1, U2 and U3. For those degrees of freedom, the term Nonlinear(n) applies only when DOF(n) = True and Fixed(n) = False.
- Ke
- Type:
System Double
- Ce
- Type:
System Double
- K
- Type:
System Double
- Slow
- Type:
System Double
This is an array of the friction coefficient at zero velocity terms when U1 is in compression for the link property. This coefficient applies for nonlinear analyses.Value Slow Slow(0) U1, not used Slow(1) U2 Slow(2) U3 Slow(3) R1, not used Slow(4) R2, not used Slow(5) R3, not used Note that this item is applicable only for degrees of freedom U2 and U3. For those degrees of freedom, the term Slow(n) applies only when DOF(n) = True, Fixed(n) = False, and Nonlinear(n) = True.
- Fast
- Type:
System Double
This is an array of the friction coefficient at fast velocity terms when U1 is in compression for the link property. This coefficient applies for nonlinear analyses.Value Fast Fast(0) U1, not used Fast(1) U2 Fast(2) U3 Fast(3) R1, not used Fast(4) R2, not used Fast(5) R3, not used Note that this item is applicable only for degrees of freedom U2 and U3. For those degrees of freedom, the term Fast(n) applies only when DOF(n) = True, Fixed(n) = False, and Nonlinear(n) = True.
- Rate
- Type:
System Double
This is an array of the inverse of the characteristic sliding velocity terms when U1 is in compression for the link property. This item applies for nonlinear analyses.Value Rate Rate(0) U1, not used Rate(1) U2 [s/L] Rate(2) U3 [s/L] Rate(3) R1, not used Rate(4) R2, not used Rate(5) R3, not used Note that this item is applicable only for degrees of freedom U2 and U3. For those degrees of freedom, the term Fast(n) applies only when DOF(n) = True, Fixed(n) = False, and Nonlinear(n) = True.
- Radius
- Type:
System Double
This is an array of the radius of the sliding contact surface terms for the link property. Inputting 0 means there is an infinite radius, that is, the slider is flat. This item applies for nonlinear analyses.Value Radius Radius(0) U1, not used Radius(1) U2 [L] Radius(2) U3 [L] Radius(3) R1, not used Radius(4) R2, not used Radius(5) R3, not used Note that this item is applicable only for degrees of freedom U2 and U3. For those degrees of freedom, the term Fast(n) applies only when DOF(n) = True, Fixed(n) = False, and Nonlinear(n) = True.
- SlowT
- Type:
System Double
This is an array of the friction coefficient at zero velocity terms when U1 is in tesion for the link property. This coefficient applies for nonlinear analyses.Value Slow SlowT(0) U1, not used SlowT(1) U2 SlowT(2) U3 SlowT(3) R1, not used SlowT(4) R2, not used SlowT(5) R3, not used Note that this item is applicable only for degrees of freedom U2 and U3. For those degrees of freedom, the term SlowT(n) applies only when DOF(n) = True, Fixed(n) = False, and Nonlinear(n) = True.
- FastT
- Type:
System Double
This is an array of the friction coefficient at fast velocity terms when U1 is in tesion for the link property. This coefficient applies for nonlinear analyses.Value Fast FastT(0) U1, not used FastT(1) U2 FastT(2) U3 FastT(3) R1, not used FastT(4) R2, not used FastT(5) R3, not used Note that this item is applicable only for degrees of freedom U2 and U3. For those degrees of freedom, the term FastT(n) applies only when DOF(n) = True, Fixed(n) = False, and Nonlinear(n) = True.
- RateT
- Type:
System Double
This is an array of the inverse of the characteristic sliding velocity terms when U1 is in tesion for the link property. This item applies for nonlinear analyses.Value Rate RateT(0) U1, not used RateT(1) U2 [s/L] RateT(2) U3 [s/L] RateT(3) R1, not used RateT(4) R2, not used RateT(5) R3, not used Note that this item is applicable only for degrees of freedom U2 and U3. For those degrees of freedom, the term RateT(n) applies only when DOF(n) = True, Fixed(n) = False, and Nonlinear(n) = True.
- Kt
- Type:
System Double
- Dis
- Type:
System Double
- Dist
- Type:
System Double
- Damping
- Type:
System Double
- DJ2
- Type:
System Double
- DJ3
- Type:
System Double
- Notes
- Type:
System String
- GUID
- Type:
System String
The GUID (global unique identifier), if any, assigned to the property.