cPropLink GetSpringData Method CSi API ETABS 2015
retrieves length and area values for a link property that are used if the link property is specified in line and area spring assignments.

Namespace: ETABS2015
Assembly: ETABS2015 (in ETABS2015.dll) Version: 15.0.0.0 (15.0.0.0)
Syntax

int GetSpringData(
	string Name,
	ref double DefinedForThisLength,
	ref double DefinedForThisArea
)

Parameters

Name
Type: OnlineSystem String
The name of an existing link property.
DefinedForThisLength
Type: OnlineSystem Double 
The link property is defined for this length in a line (frame) spring. [L]
DefinedForThisArea
Type: OnlineSystem Double 
The link property is defined for this area in an area spring. [L2]

Return Value

Returns zero if the values are successfully retieved; otherwise it returns a nonzero value.
Remarks

Examples

See Also