cFrameObj DeleteLoadPoint Method CSi API ETABS 2015
Deletes the point load assignments to the specified frame objects for the specified load pattern.

Namespace: ETABS2015
Assembly: ETABS2015 (in ETABS2015.dll) Version: 15.0.0.0 (15.0.0.0)
Syntax

int DeleteLoadPoint(
	string Name,
	string LoadPat,
	eItemType ItemType = eItemType.Objects
)

Parameters

Name
Type: OnlineSystem String
The name of an existing frame object or group depending on the value of the ItemType item.
LoadPat
Type: OnlineSystem String
The name of a defined load pattern.
ItemType (Optional)
Type: ETABS2015 eItemType
This is one of the following items in the eItemType enumeration:
  • Object = 0
  • Group = 1
  • SelectedObjects = 2

If this item is Objects, the load assignments are deleted for the frame object specified by the Name item.

If this item is Group, the load assignments are deleted for all frame objects in the group specified by the Name item.

If this item is SelectedObjects, the load assignments are deleted for all selected frame objects, and the Name item is ignored.

Return Value

Returns zero if the load assignments are successfully deleted, otherwise it returns a nonzero value.
Remarks

Examples

See Also