Initializes a static linear load case.
Namespace: ETABS2015Assembly: ETABS2015 (in ETABS2015.dll) Version: 15.0.0.0 (15.0.0.0)
int SetCase(
string Name
)
Function SetCase ( _
Name As String _
) As Integer
int SetCase(
String^ Name
)
Parameters
- Name
- Type:
System String
The name of an existing or new load case. If this is an existing case,
that case is modified; otherwise, a new case is added.
Return Value
Returns zero if the load case is successfully initialized;
otherwise it returns a nonzero value.
If this function is called for an existing load case,
all items for the case are reset to their default value.
Public Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4, 12, 12, 4, 4, 24, 24)
ret = SapModel.LoadCases.StaticLinear.SetCase("LCASE1")
ret = SapModel.View.RefreshView(0, False)
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
Public Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
'create ETABS object
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
'start ETABS application
ret = EtabsObject.ApplicationStart()
'create SapModel object
SapModel = EtabsObject.SapModel
'initialize model
ret = SapModel.InitializeNewModel()
'create steel deck template model
ret = SapModel.File.NewSteelDeck(4, 12, 12, 4, 4, 24, 24)
'add static linear load case
ret = SapModel.LoadCases.StaticLinear.SetCase("LCASE1")
'refresh view
ret = SapModel.View.RefreshView(0, False)
'close ETABS
EtabsObject.ApplicationExit(False)
'clean up variables
SapModel = Nothing
EtabsObject = Nothing
End Sub