cLinkObj AddByPoint Method CSi API ETABS 2015
Adds a new link object whose end points are specified by name.

Namespace: ETABS2015
Assembly: ETABS2015 (in ETABS2015.dll) Version: 15.0.0.0 (15.0.0.0)
Syntax

int AddByPoint(
	string Point1,
	string Point2,
	ref string Name,
	bool IsSingleJoint = false,
	string PropName = "Default",
	string UserName = ""
)

Parameters

Point1
Type: OnlineSystem String
The name of a defined point object at the I-End of the added link object.
Point2
Type: OnlineSystem String
The name of a defined point object at the J-End of the added link object.

This item is ignored if the IsSingleJoint item is True.

Name
Type: OnlineSystem String 
This is the name that the program ultimately assigns for the link object. If no UserName is specified, the program assigns a default name to the link object. If a UserName is specified and that name is not used for another link object, the UserName is assigned to the link object; otherwise a default name is assigned to the link object.
IsSingleJoint (Optional)
Type: OnlineSystem Boolean
This item is True if a one-joint link is added and False if a two-joint link is added.
PropName (Optional)
Type: OnlineSystem String
This is either Default or the name of a defined link property.

If it is Default the program assigns a default link property to the link object. If it is the name of a defined link property, that property is assigned to the link object

UserName (Optional)
Type: OnlineSystem String

Return Value

Returns zero if the link object is successfully added; otherwise it returns a nonzero value.
Remarks

One-joint links are not supported in ETABS.
Examples

See Also