cCombo SetCaseList Method CSi API ETABS 2015
Adds or modifies one load case or response combination in the list of cases included in the load combination specified by the Name item.

Namespace: ETABS2015
Assembly: ETABS2015 (in ETABS2015.dll) Version: 15.0.0.0 (15.0.0.0)
Syntax

int SetCaseList(
	string Name,
	ref eCNameType CNameType,
	string CName,
	double SF
)

Parameters

Name
Type: OnlineSystem String
The name of an existing load combination.
CNameType
Type: ETABS2015 eCNameType 
This is one of the following items in the eCNameType enumeration:
  • LoadCase = 0
  • LoadCombo = 1

This item indicates whether the CName item is an analysis case (LoadCase) or a load combination (LoadCombo).

CName
Type: OnlineSystem String
The name of the load case or load combination to be added to or modified in the combination specified by the Name item. If the load case or combination already exists in the combination specified by the Name item, the scale factor is modified as indicated by the sf item for that load case or combination. If the analysis case or combination does not exist in the combination specified by the Name item, it is added.
SF
Type: OnlineSystem Double

Return Value

Returns zero if the item is successfully added or modified, otherwise it returns a nonzero value.
Remarks

Examples

See Also