cFrameObj GetLoadPoint Method CSi API ETABS 2015
Retrieves the point load assignments to frame objects.

Namespace: ETABS2015
Assembly: ETABS2015 (in ETABS2015.dll) Version: 15.0.0.0 (15.0.0.0)
Syntax

int GetLoadPoint(
	string Name,
	ref int NumberItems,
	ref string[] FrameName,
	ref string[] LoadPat,
	ref int[] MyType,
	ref string[] CSys,
	ref int[] Dir,
	ref double[] RelDist,
	ref double[] Dist,
	ref double[] Val,
	eItemType ItemType = eItemType.Objects
)

Parameters

Name
Type: OnlineSystem String
The name of an existing frame object or group, depending on the value of the ItemType item.
NumberItems
Type: OnlineSystem Int32 
The total number of point loads retrieved for the specified frame objects.
FrameName
Type:  OnlineSystem String  
This is an array that includes the name of the frame object associated with each point load.
LoadPat
Type:  OnlineSystem String  
This is an array that includes the name of the load pattern associated with each point load.
MyType
Type:  OnlineSystem Int32  
This is an array that includes 1 or 2, indicating the type of point load.
  1. Force
  2. Moment
CSys
Type:  OnlineSystem String  
This is an array that includes the name of the coordinate system in which each point load is defined. It may be Local or the name of a defined coordinate system.
Dir
Type:  OnlineSystem Int32  
RelDist
Type:  OnlineSystem Double  
This is an array that includes the relative distance from the I-End of the frame object to the location where the point load is applied.
Dist
Type:  OnlineSystem Double  
Val
Type:  OnlineSystem Double  
ItemType (Optional)
Type: ETABS2015 eItemType
This is one of the following items in the eItemType enumeration:
  • Object = 0
  • Group = 1
  • SelectedObjects = 2

If this item is Objects, the assignments are retrieved for the frame object specified by the Name item.

If this item is Group, the assignments are retrieved for all frame objects in the group specified by the Name item.

If this item is SelectedObjects, the assignments are retrieved for all selected frame objects and the Name item is ignored.

Return Value

Returns zero if the load assignments are successfully retrieved, otherwise it returns a nonzero value.
Remarks

Examples

See Also