Adds a new load pattern.
Namespace: ETABS2015Assembly: ETABS2015 (in ETABS2015.dll) Version: 15.0.0.0 (15.0.0.0)
int Add(
string Name,
eLoadPatternType MyType,
double SelfWTMultiplier = 0,
bool AddAnalysisCase = true
)
Function Add ( _
Name As String, _
MyType As eLoadPatternType, _
Optional SelfWTMultiplier As Double = 0, _
Optional AddAnalysisCase As Boolean = True _
) As Integer
int Add(
String^ Name,
eLoadPatternType MyType,
double SelfWTMultiplier = 0,
bool AddAnalysisCase = true
)
Parameters
- Name
- Type:
System String
The name for the new load pattern.
- MyType
- Type: ETABS2015 eLoadPatternType
This is one of the items in the eLoadPatternType enumeration.
- SelfWTMultiplier (Optional)
- Type:
System Double
The self weight multiplier for the new load pattern.
- AddAnalysisCase (Optional)
- Type:
System Boolean
If this item is True, a linear static load case corresponding
to the new load pattern is added.
Return Value
Returns 0 if the load pattern is successfully added; otherwise it returns nonzero.
An error is returned if the
Name item is already used
for an existing load pattern.
Public Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)
ret = SapModel.LoadPatterns.Add("LIVE1A", ETABS2013.eLoadPatternType.Live)
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
Public Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
'create ETABS object
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
'start ETABS application
ret = EtabsObject.ApplicationStart()
'create SapModel object
SapModel = EtabsObject.SapModel
'initialize model
ret = SapModel.InitializeNewModel()
'create steel deck template model
ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)
'add new load pattern
ret = SapModel.LoadPatterns.Add("LIVE1A", ETABS2013.eLoadPatternType.Live)
'close ETABS
EtabsObject.ApplicationExit(False)
'clean up variables
SapModel = Nothing
EtabsObject = Nothing
End Sub