cCaseStaticLinear GetLoads Method CSi API ETABS 2015
Retrieves the load data for the specified load case

Namespace: ETABS2015
Assembly: ETABS2015 (in ETABS2015.dll) Version: 15.0.0.0 (15.0.0.0)
Syntax

int GetLoads(
	string Name,
	ref int NumberLoads,
	ref string[] LoadType,
	ref string[] LoadName,
	ref double[] SF
)

Parameters

Name
Type: OnlineSystem String
The name of an existing static linear load case.
NumberLoads
Type: OnlineSystem Int32 
The number of loads assigned to the specified analysis case.
LoadType
Type:  OnlineSystem String  
This is an array that includes either Load or Accel, indicating the type of each load assigned to the load case.
LoadName
Type:  OnlineSystem String  
This is an array that includes the name of each load assigned to the load case.

If the LoadType item is Load, this item is the name of a defined load pattern.

If the LoadType item is Accel, this item is UX, UY, UZ, RX, RY or RZ, indicating the direction of the load.

SF
Type:  OnlineSystem Double  

Return Value

Returns zero if the data is successfully retrieved; otherwise it returns a nonzero value.
Remarks

Examples

See Also