cPropArea GetNameList Method CSi API ETABS 2015
Retrieves the names of all defined area properties of the specified type.

Namespace: ETABS2015
Assembly: ETABS2015 (in ETABS2015.dll) Version: 15.0.0.0 (15.0.0.0)
Syntax

int GetNameList(
	ref int NumberNames,
	ref string[] MyName,
	int PropType = 0
)

Parameters

NumberNames
Type: OnlineSystem Int32 
The number of area property names retrieved by the program.
MyName
Type:  OnlineSystem String  
One-dimensional array of area property names. The MyName array is created as a dynamic, zero-based, array by the API user:

Dim MyName() as String

The array is dimensioned to (NumberNames - 1) inside the program, filled with the names, and returned to the API user.
PropType (Optional)
Type: OnlineSystem Int32
This optional value is 0, 1, 2 or 3, indicating the type of area properties included in the name list.
ValueType
0All
1Shell
2Plane
3Asolid

Return Value

Returns zero if the names are successfully retrieved; otherwise it returns nonzero
Remarks

Examples

See Also