cPropLink GetPDelta Method CSi API ETABS 2015
retrieves P-delta parameters for a link property.

Namespace: ETABS2015
Assembly: ETABS2015 (in ETABS2015.dll) Version: 15.0.0.0 (15.0.0.0)
Syntax

int GetPDelta(
	string Name,
	ref double[] Value
)

Parameters

Name
Type: OnlineSystem String
The name of an existing link property.
Value
Type:  OnlineSystem Double  
This is an array of P-delta parameters
ValuePDelta Parameter
Value(0)M2 P-delta to I-end of link as moment, M2I
Value(1)M2 P-delta to J-end of link as moment, M2J
Value(2)M3 P-delta to I-end of link as moment, M3I
Value(3)M3 P-delta to J-end of link as moment, M3J

Return Value

Returns zero if the values are successfully retrieved; otherwise it returns a nonzero value.
Remarks

Examples

See Also