cPropArea GetSlabRibbed Method CSi API ETABS 2015
Retrieves property data for a ribbed slab section.

Namespace: ETABS2015
Assembly: ETABS2015 (in ETABS2015.dll) Version: 15.0.0.0 (15.0.0.0)
Syntax

int GetSlabRibbed(
	string Name,
	ref double OverallDepth,
	ref double SlabThickness,
	ref double StemWidthTop,
	ref double StemWidthBot,
	ref double RibSpacing,
	ref int RibsParallelTo
)

Parameters

Name
Type: OnlineSystem String
The name of an existing ribbed slab property.
OverallDepth
Type: OnlineSystem Double 
Overall Depth
SlabThickness
Type: OnlineSystem Double 
Slab Thickness
StemWidthTop
Type: OnlineSystem Double 
Stem Width at Top
StemWidthBot
Type: OnlineSystem Double 
Stem Width at Bottom
RibSpacing
Type: OnlineSystem Double 
Rib Spacing (Perpendicular to Rib Direction)
RibsParallelTo
Type: OnlineSystem Int32 
This is the Local Axis that the Rib Direction is Parallel to

This value is 1 for the Local 1 Axis, and 2 for the Local 2 Axis.

Return Value

The function returns zero if the property data is successfully retrieved; otherwise it returns a nonzero value.
Remarks

Examples

See Also