Returns the total number of defined area properties in the model.
If desired, counts can be returned for all area properties of a specified type in the model.
Namespace: ETABS2015Assembly: ETABS2015 (in ETABS2015.dll) Version: 15.0.0.0 (15.0.0.0)
int Count(
int PropType = 0
)
Function Count ( _
Optional PropType As Integer = 0 _
) As Integer
int Count(
int PropType = 0
)
Parameters
- PropType (Optional)
- Type:
System Int32
This optional value is 0, 1, 2 or 3, indicating the type of
area properties included in the count.
Value | Type |
---|
0 | All |
1 | Shell |
2 | Plane |
3 | Asolid |
Return Value
The total number of defined area properties in the model.
Plane and Asolid area properties are not supported in ETABS.
Public Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
Dim Count as Integer
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)
Count = SapModel.PropArea.Count
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
Public Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
Dim Count as Integer
'create ETABS object
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
'start ETABS application
ret = EtabsObject.ApplicationStart()
'create SapModel object
SapModel = EtabsObject.SapModel
'initialize model
ret = SapModel.InitializeNewModel()
'create steel deck template model
ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)
'return number of defined area properties of all types
Count = SapModel.PropArea.Count
'close ETABS
EtabsObject.ApplicationExit(False)
'clean up variables
SapModel = Nothing
EtabsObject = Nothing
End Sub