Retrieves frame object insertion point assignments.
The assignments include the cardinal point and end joint offsets.
Namespace: ETABS2015Assembly: ETABS2015 (in ETABS2015.dll) Version: 15.0.0.0 (15.0.0.0)
int GetInsertionPoint(
string Name,
ref int CardinalPoint,
ref bool Mirror2,
ref bool StiffTransform,
ref double[] Offset1,
ref double[] Offset2,
ref string CSys
)
Function GetInsertionPoint ( _
Name As String, _
ByRef CardinalPoint As Integer, _
ByRef Mirror2 As Boolean, _
ByRef StiffTransform As Boolean, _
ByRef Offset1 As Double(), _
ByRef Offset2 As Double(), _
ByRef CSys As String _
) As Integer
int GetInsertionPoint(
String^ Name,
int% CardinalPoint,
bool% Mirror2,
bool% StiffTransform,
array<double>^% Offset1,
array<double>^% Offset2,
String^% CSys
)
Parameters
- Name
- Type:
System String
The name of an existing frame object.
- CardinalPoint
- Type:
System Int32
This is a numeric value from 1 to 11 that specifies the cardinal point
for the frame object. The cardinal point specifies the relative position
of the frame section on the line representing the frame object.
- bottom left
- bottom center
- bottom right
- middle left
- middle center
- middle right
- top left
- top center
- top right
- centroid
- shear center
- Mirror2
- Type:
System Boolean
If this item is True, the frame object section is assumed to be
mirrored (flipped) about its local 2-axis.
- StiffTransform
- Type:
System Boolean
If this item is True, the frame object stiffness is transformed
for cardinal point and joint offsets from the frame section centroid.
- Offset1
- Type:
System Double
This is an array of three joint offset distances, in the
coordinate directions specified by CSys, at the I-End of the frame object. [L]
- Offset1(0) = Offset in the 1-axis or X-axis direction
- Offset1(1) = Offset in the 2-axis or Y-axis direction
- Offset1(2) = Offset in the 3-axis or Z-axis direction
- Offset2
- Type:
System Double
This is an array of three joint offset distances, in the
coordinate directions specified by CSys, at the J-End of the frame object. [L]
- Offset2(0) = Offset in the 1-axis or X-axis direction
- Offset2(1) = Offset in the 2-axis or Y-axis direction
- Offset2(2) = Offset in the 3-axis or Z-axis direction
- CSys
- Type:
System String
This is Local or the name of a defined coordinate system.
It is the coordinate system in which the Offset1 and
Offset2 items are specified.
Return Value
Returns zero if the insertion point data is successfully retrieved,
otherwise it returns a nonzero value.
Public Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4, 12, 12, 4, 4, 24, 24)
ReDim Offset1(2)
ReDim Offset2(2)
For i=0 To 2
Offset1(i)=10 + i
Offset2(i)=20 + i
Next i
ret = SapModel.FrameObj.SetInsertionPoint("15", 7, False, True, Offset1, Offset2)
ReDim Offset1(2)
ReDim Offset2(2)
ret = SapModel.FrameObj.GetInsertionPoint("15", CardinalPoint, Mirror2, StiffTransform, Offset1, Offset2, CSys)
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
Public Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
'create ETABS object
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
'start ETABS application
ret = EtabsObject.ApplicationStart()
'create SapModel object
SapModel = EtabsObject.SapModel
'initialize model
ret = SapModel.InitializeNewModel()
'create steel deck template model
ret = SapModel.File.NewSteelDeck(4, 12, 12, 4, 4, 24, 24)
'assign frame insertion point
ReDim Offset1(2)
ReDim Offset2(2)
For i=0 To 2
Offset1(i)=10 + i
Offset2(i)=20 + i
Next i
ret = SapModel.FrameObj.SetInsertionPoint("15", 7, False, True, Offset1, Offset2)
'get frame insertion point
ReDim Offset1(2)
ReDim Offset2(2)
ret = SapModel.FrameObj.GetInsertionPoint("15", CardinalPoint, Mirror2, StiffTransform, Offset1, Offset2, CSys)
'close ETABS
EtabsObject.ApplicationExit(False)
'clean up variables
SapModel = Nothing
EtabsObject = Nothing
End Sub