cStory GetNameList Method CSi API ETABS 2015
Retrieves the names of all defined stories

Namespace: ETABS2015
Assembly: ETABS2015 (in ETABS2015.dll) Version: 15.0.0.0 (15.0.0.0)
Syntax

int GetNameList(
	ref int NumberNames,
	ref string[] MyName
)

Parameters

NumberNames
Type: OnlineSystem Int32 
The number of stories
MyName
Type:  OnlineSystem String  
This is a one-dimensional array of names. The MyName array is created as a dynamic, zero-based, array by the API user:

Dim MyName() as String

The array is dimensioned to (NumberNames – 1) inside the program, filled with the names, and returned to the API user.

Return Value

Returns zero if the names are successfully retrieved, otherwise returns nonzero.
Remarks

Examples

See Also