cStory SetStories Method CSi API ETABS 2015
Sets the stories for the current tower

Namespace: ETABS2015
Assembly: ETABS2015 (in ETABS2015.dll) Version: 15.0.0.0 (15.0.0.0)
Syntax

int SetStories(
	string[] StoryNames,
	double[] StoryElevations,
	double[] StoryHeights,
	bool[] IsMasterStory,
	string[] SimilarToStory,
	bool[] SpliceAbove,
	double[] SpliceHeight
)

Parameters

StoryNames
Type:  OnlineSystem String 
The names of the stories
StoryElevations
Type:  OnlineSystem Double 
The story elevations. This array has length (Number of stories + 1). The first value in the array is the "Base" elevation, commonly 0.
StoryHeights
Type:  OnlineSystem Double 
The story heights. Although this argument is not optional, an empty array may be used. This array has length (Number of stories), with no value for "Base"
IsMasterStory
Type:  OnlineSystem Boolean 
Whether the story is a master story. This array has length (Number of stories), with no value for "Base"
SimilarToStory
Type:  OnlineSystem String 
If the story is not a master story, which master story the story is similar to. This array has length (Number of stories), with no value for "Base"
SpliceAbove
Type:  OnlineSystem Boolean 
This is True if the story has a splice height, and False otherwise. This array has length (Number of stories), with no value for "Base"
SpliceHeight
Type:  OnlineSystem Double 
The story splice heights, if applicable. This array has length (Number of stories), with no value for "Base"

Return Value

Returns zero if the story data is successfully set, otherwise returns nonzero.
Remarks

To change the current tower, use SetActiveTower(String)
Examples

See Also