cFrameObj SetTCLimits Method CSi API ETABS 2015
Makes tension/compression force limit assignments to frame objects.

Namespace: ETABS2015
Assembly: ETABS2015 (in ETABS2015.dll) Version: 15.0.0.0 (15.0.0.0)
Syntax

int SetTCLimits(
	string Name,
	bool LimitCompressionExists,
	double LimitCompression,
	bool LimitTensionExists,
	double LimitTension,
	eItemType ItemType = eItemType.Objects
)

Parameters

Name
Type: OnlineSystem String
The name of an existing frame object or group depending on the value of the ItemType item.
LimitCompressionExists
Type: OnlineSystem Boolean
This item is True if a compression force limit exists for the frame object.
LimitCompression
Type: OnlineSystem Double
The compression force limit for the frame object. [F]
LimitTensionExists
Type: OnlineSystem Boolean
This item is True if a tension force limit exists for the frame object.
LimitTension
Type: OnlineSystem Double
The tension force limit for the frame object. [F]
ItemType (Optional)
Type: ETABS2015 eItemType
This is one of the following items in the eItemType enumeration:
  • Object = 0
  • Group = 1
  • SelectedObjects = 2

If this item is Objects, the assignment is made to the frame object specified by the Name item.

If this item is Group, the assignment is made to all frame objects in the group specified by the Name item.

If this item is SelectedObjects, the assignment is made to all selected frame objects and the Name item is ignored.

Return Value

Returns zero if the assignments are successfully applied, otherwise it returns a nonzero value.
Remarks

Note that the tension and compression limits are only used in nonlinear analyses.
Examples

See Also