Sets the value of a steel design overwrite item.
Namespace: ETABS2015Assembly: ETABS2015 (in ETABS2015.dll) Version: 15.0.0.0 (15.0.0.0)
Syntax
Parameters
- Name
- Type:
System String
The name of an existing frame object or group, depending on the value of the ItemType item.
- Item
- Type:
System Int32
This is an integer between 1 and 43, inclusive, indicating the overwrite item considered.- Framing type
- Omega0
- Consider deflection
- Deflection check type
- DL deflection limit, L/Value
- SDL + LL deflection limit, L/Value
- LL deflection limit, L/Value
- Total load deflection limit, L/Value
- Total camber limit, L/Value
- DL deflection limit, absolute
- SDL + LL deflection limit, absolute
- LL deflection limit, absolute
- Total load deflection limit, absolute
- Total camber limit, absolute
- Specified camber
- Net area to total area ratio
- Live load reduction factor
- Unbraced length ratio, Major
- Unbraced length ratio, Minor
- Unbraced length ratio, Lateral Torsional Buckling
- Effective length factor, K1 Major
- Effective length factor, K1 Minor
- Effective length factor, K2 Major
- Effective length factor, K2 Minor
- Effective length factor, K Lateral Torsional Buckling
- Moment coefficient, Cm Major
- Moment coefficient, Cm Minor
- Bending coefficient, Cb
- Nonsway moment factor, B1 Major
- Nonsway moment factor, B1 Minor
- Sway moment factor, B2 Major
- Sway moment factor, B2 Minor
- Reduce HSS thickness
- HSS welding type
- Yield stress, Fy
- Expected to specified Fy ratio, Ry
- Compressive capacity, Pnc
- Tensile capacity, Pnt
- Major bending capacity, Mn3
- Minor bending capacity, Mn2
- Major shear capacity, Vn2
- Minor shear capacity, Vn3
- Demand/capacity ratio limit
- Value
- Type:
System Double
The value of the considered overwrite item.-
Framing type
- 0 = Program Default
- 1 = SMF
- 2 = IMF
- 3 = OMF
- 4 = SCBF
- 5 = OCBF
- 6 = OCBFI
- 7 = EBF
- Omega0 Value >= 0; 0 means use a program determined value.
-
Consider deflection
- 0 = Program Default
- 1 = No
- 2 = Yes
-
Deflection check type
- 0 = Program Default
- 1 = Ratio
- 2 = Absolute
- 3 = Both
- DL deflection limit, L/Value Value >= 0; 0 means no check for this item.
- SDL + LL deflection limit, L/Value Value >= 0; 0 means no check for this item.
- LL deflection limit, L/Value Value >= 0; 0 means no check for this item.
- Total load deflection limit, L/Value Value >= 0; 0 means no check for this item.
- Total camber limit, L/Value Value >= 0; 0 means no check for this item.
- DL deflection limit, absolute Value >= 0; 0 means no check for this item. [L]
- SDL + LL deflection limit, absolute Value >= 0; 0 means no check for this item. [L]
- LL deflection limit, absolute Value >= 0; 0 means no check for this item. [L]
- Total load deflection limit, absolute Value >= 0; 0 means no check for this item. [L]
- Total camber limit, absolute Value >= 0; 0 means no check for this item. [L]
- Specified camber Value >= 0. [L]
- Net area to total area ratio Value >= 0; 0 means use program default value.
- Live load reduction factor Value >= 0; 0 means use program determined value.
- Unbraced length ratio, Major Value >= 0; 0 means use program determined value.
- Unbraced length ratio, Minor Value >= 0; 0 means use program determined value.
- Unbraced length ratio, Lateral Torsional Buckling Value >= 0; 0 means use program determined value.
- Effective length factor, K1 Major Value >= 0; 0 means use program determined value.
- Effective length factor, K1 Minor Value >= 0; 0 means use program determined value.
- Effective length factor, K2 Major Value >= 0; 0 means use program determined value.
- Effective length factor, K2 Minor Value >= 0; 0 means use program determined value.
- Effective length factor, K Lateral Torsional Buckling Value >= 0; 0 means use program determined value.
- Moment coefficient, Cm Major Value >= 0; 0 means use program determined value.
- Moment coefficient, Cm Minor Value >= 0; 0 means use program determined value.
- Bending coefficient, Cb Value >= 0; 0 means use program determined value.
- Nonsway moment factor, B1 Major Value >= 0; 0 means use program determined value.
- Nonsway moment factor, B1 Minor Value >= 0; 0 means use program determined value.
- Sway moment factor, B2 Major Value >= 0; 0 means use program determined value.
- Sway moment factor, B2 Minor Value >= 0; 0 means use program determined value.
-
Reduce HSS thickness
- 0 = Program Default
- 1 = No
- 2 = Yes
-
HSS welding type
- 0 = Program Default
- 1 = ERW
- 2 = SAW
- Yield stress, Fy Value >= 0; 0 means use program determined value. [F/L^2]
- Expected to specified Fy ratio, Ry Value >= 0; 0 means use program determined value.
- Compressive capacity, Pnc Value >= 0; 0 means use program determined value. [F]
- Tensile capacity, Pnt Value >= 0; 0 means use program determined value. [F]
- Major bending capacity, Mn3 Value >= 0; 0 means use program determined value. [FL]
- Minor bending capacity, Mn2 Value >= 0; 0 means use program determined value. [FL]
- Major shear capacity, Vn2 Value >= 0; 0 means use program determined value. [F]
- Minor shear capacity, Vn3 Value >= 0; 0 means use program determined value. [F]
- Demand/capacity ratio limit Value >= 0; 0 means use program determined value.
-
Framing type
- ItemType (Optional)
- Type: ETABS2015 eItemType
This is one of the following items in the eItemType enumeration:- Object = 0
- Group = 1
- SelectedObjects = 2
If this item is Objects, the assignment is made to the frame object specified by the Name item.
If this item is Group, the assignment is made to all frame objects in the group specified by the Name item.
If this item is SelectedObjects, the assignment is made to all selected frame objects and the Name item is ignored.
Return Value
Returns zero if the item is successfully set; otherwise it returns a nonzero value.Remarks
Examples
See Also