Returns a string that represents the filename of the current model,
with or without the full path.
Namespace: ETABS2015Assembly: ETABS2015 (in ETABS2015.dll) Version: 15.0.0.0 (15.0.0.0)
string GetModelFilename(
bool IncludePath = true
)
string GetModelFilename(
bool IncludePath = true
)
Function GetModelFilename ( _
Optional IncludePath As Boolean = True _
) As String
Function GetModelFilename ( _
Optional IncludePath As Boolean = True _
) As String
String^ GetModelFilename(
bool IncludePath = true
)
String^ GetModelFilename(
bool IncludePath = true
)
Parameters
- IncludePath (Optional)
- Type:
System Boolean
A boolean (True or False) value. When this item is True,
the returned filename includes the full path where the file is located.
Return Value
Returns a string that represents the filename of the current model,
with or without the full path.
Public Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.File.Save("C:\CSI_API_temp\API_1-001.edb")
MsgBox(SapModel.GetModelFilename())
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
Public Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
'create ETABS object
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
'start ETABS application
ret = EtabsObject.ApplicationStart()
'create SapModel object
SapModel = EtabsObject.SapModel
'save the model
ret = SapModel.File.Save("C:\CSI_API_temp\API_1-001.edb")
'display the filename of the model
MsgBox(SapModel.GetModelFilename())
'close ETABS
EtabsObject.ApplicationExit(False)
'clean up variables
SapModel = Nothing
EtabsObject = Nothing
End Sub