cFrameObj GetDesignProcedure Method CSi API ETABS 2015
Retrieves the design procedure for a frame object

Namespace: ETABS2015
Assembly: ETABS2015 (in ETABS2015.dll) Version: 15.0.0.0 (15.0.0.0)
Syntax

int GetDesignProcedure(
	string Name,
	ref int MyType
)

Parameters

Name
Type: OnlineSystem String
The name of an existing frame object
MyType
Type: OnlineSystem Int32 
This is an integer from the list below, indicating the design procedure type of the specified frame object.
  • Program determined = 0
  • Steel Frame Design = 1
  • Concrete Frame Design = 2
  • Composite Beam Design = 3
  • Steel Joist Design = 4
  • No Design = 7
  • Composite Column Design = 13

Return Value

Returns zero if the design procedure is successfully retrieved; otherwise it returns a nonzero value
Remarks

Examples

See Also