cPropLink GetMultiLinearPoints Method CSi API ETABS 2015
Retrieves the force-deformation data for a specified degree of freedom in multilinear elastic and multilinear plastic link properties.

Namespace: ETABS2015
Assembly: ETABS2015 (in ETABS2015.dll) Version: 15.0.0.0 (15.0.0.0)
Syntax

int GetMultiLinearPoints(
	string Name,
	int DOF,
	ref int NumberPoints,
	ref double[] F,
	ref double[] D,
	ref int MyType,
	ref double A1,
	ref double A2,
	ref double B1,
	ref double B2,
	ref double Eta
)

Parameters

Name
Type: OnlineSystem String
The name of an existing multilinear elastic or multilinear plastic link property.
DOF
Type: OnlineSystem Int32
NumberPoints
Type: OnlineSystem Int32 
The number of foce-defomation points for the specified degree of freedom.
F
Type:  OnlineSystem Double  
This is an array, dimensioned to NumberPoints - 1, that includes the force at each point. When DOF is U1, U2 or U3, this is a force. When DOF is R1, R2 or R3. this is a moment. [F] if DOF is less than or equal to 3, and [FL] if DOF is greater than 3.
D
Type:  OnlineSystem Double  
MyType
Type: OnlineSystem Int32 
This item applies only to multilinear plastic link properties. It is 1, 2 or 3, indicating the hysteresis type.
MyTpeHysteresis Type
1Kinematic
2Takeda
3Pivot
A1
Type: OnlineSystem Double 
A2
Type: OnlineSystem Double 
B1
Type: OnlineSystem Double 
B2
Type: OnlineSystem Double 
Eta
Type: OnlineSystem Double 

Return Value

Returns zero if the data is successfully assigned; otherwise it returns a nonzero value.
Remarks

To successfully retrieve this data from the indicated link property, the following conditions must be met:
  1. The link property must be multilinear elastic or multilinear plastic.
  2. The specified DOF must be active.
  3. The specified DOF must not be fixed.
  4. The specified DOF must be nonlinear.
Examples

See Also