Assigns frame object output station data.
Namespace: ETABS2015Assembly: ETABS2015 (in ETABS2015.dll) Version: 15.0.0.0 (15.0.0.0)
int SetOutputStations(
string Name,
int MyType,
double MaxSegSize,
int MinSections,
bool NoOutPutAndDesignAtElementEnds = false,
bool NoOutPutAndDesignAtPointLoads = false,
eItemType ItemType = eItemType.Objects
)
Function SetOutputStations ( _
Name As String, _
MyType As Integer, _
MaxSegSize As Double, _
MinSections As Integer, _
Optional NoOutPutAndDesignAtElementEnds As Boolean = False, _
Optional NoOutPutAndDesignAtPointLoads As Boolean = False, _
Optional ItemType As eItemType = eItemType.Objects _
) As Integer
int SetOutputStations(
String^ Name,
int MyType,
double MaxSegSize,
int MinSections,
bool NoOutPutAndDesignAtElementEnds = false,
bool NoOutPutAndDesignAtPointLoads = false,
eItemType ItemType = eItemType::Objects
)
Parameters
- Name
- Type:
System String
The name of an existing frame object or group, depending on the
value of the ItemType item.
- MyType
- Type:
System Int32
This is 1 or 2, indicating how the output stations are specified.
- maximum segment size, that is, maximum station spacing
- minimum number of stations
- MaxSegSize
- Type:
System Double
The maximum segment size, that is, the maximum station spacing.
This item applies only when MyType = 1. [L]
- MinSections
- Type:
System Int32
The minimum number of stations. This item applies only when
MyType = 2.
- NoOutPutAndDesignAtElementEnds (Optional)
- Type:
System Boolean
If this item is True, no additional output stations are added
at the ends of line elements when the frame object is internally meshed.
In ETABS, this item will always be False
- NoOutPutAndDesignAtPointLoads (Optional)
- Type:
System Boolean
If this item is True, no additional output stations are added
at point load locations. In ETABS, this item will always be False
- ItemType (Optional)
- Type: ETABS2015 eItemType
This is one of the following items in the eItemType enumeration:
- Object = 0
- Group = 1
- SelectedObjects = 2
If this item is Objects, the assignment is made to the frame object
specified by the Name item.
If this item is Group, the assignment is made to all frame objects
in the group specified by the Name item.
If this item is SelectedObjects, the assignment is made to all
selected frame objects and the Name item is ignored.
Return Value
Returns zero if the data is successfully assigned,
otherwise it returns a nonzero value.
Public Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4, 12, 12, 4, 4, 24, 24)
ret = SapModel.FrameObj.SetOutputStations("15", 1, 18, 0)
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
Public Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
'create ETABS object
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
'start ETABS application
ret = EtabsObject.ApplicationStart()
'create SapModel object
SapModel = EtabsObject.SapModel
'initialize model
ret = SapModel.InitializeNewModel()
'create steel deck template model
ret = SapModel.File.NewSteelDeck(4, 12, 12, 4, 4, 24, 24)
'assign frame output station data
ret = SapModel.FrameObj.SetOutputStations("15", 1, 18, 0)
'close ETABS
EtabsObject.ApplicationExit(False)
'clean up variables
SapModel = Nothing
EtabsObject = Nothing
End Sub