Retrieves frame object output station data
Namespace: ETABS2015Assembly: ETABS2015 (in ETABS2015.dll) Version: 15.0.0.0 (15.0.0.0)
int GetOutputStations(
string Name,
ref int MyType,
ref double MaxSegSize,
ref int MinSections,
ref bool NoOutPutAndDesignAtElementEnds,
ref bool NoOutPutAndDesignAtPointLoads
)
int GetOutputStations(
string Name,
ref int MyType,
ref double MaxSegSize,
ref int MinSections,
ref bool NoOutPutAndDesignAtElementEnds,
ref bool NoOutPutAndDesignAtPointLoads
)
Function GetOutputStations ( _
Name As String, _
ByRef MyType As Integer, _
ByRef MaxSegSize As Double, _
ByRef MinSections As Integer, _
ByRef NoOutPutAndDesignAtElementEnds As Boolean, _
ByRef NoOutPutAndDesignAtPointLoads As Boolean _
) As Integer
Function GetOutputStations ( _
Name As String, _
ByRef MyType As Integer, _
ByRef MaxSegSize As Double, _
ByRef MinSections As Integer, _
ByRef NoOutPutAndDesignAtElementEnds As Boolean, _
ByRef NoOutPutAndDesignAtPointLoads As Boolean _
) As Integer
int GetOutputStations(
String^ Name,
int% MyType,
double% MaxSegSize,
int% MinSections,
bool% NoOutPutAndDesignAtElementEnds,
bool% NoOutPutAndDesignAtPointLoads
)
int GetOutputStations(
String^ Name,
int% MyType,
double% MaxSegSize,
int% MinSections,
bool% NoOutPutAndDesignAtElementEnds,
bool% NoOutPutAndDesignAtPointLoads
)
Parameters
- Name
- Type:
System String
The name of an existing frame object
- MyType
- Type:
System Int32
This is either 1 or 2 indicating how the output stations are specified
- maximum segment size, that is, maximum station spacing
- minimum number of stations
- MaxSegSize
- Type:
System Double
The maximum segment size, that is, the maximum station spacing. This item applies only when MyType = 1. [L]
- MinSections
- Type:
System Int32
The minimum number of stations. This item applies only when MyType = 2.
- NoOutPutAndDesignAtElementEnds
- Type:
System Boolean
If this item is True, no additional output stations are added at the ends of line elements
when the frame object is internally meshed. In ETABS, this item will always be False.
- NoOutPutAndDesignAtPointLoads
- Type:
System Boolean
If this item is True, no additional output stations are added at point load locations.
In ETABS, this item will always be False.
Return Value
Returns zero if the data is successfully retrieved, otherwise it returns a nonzero value
Public Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
Dim MyType As Integer
Dim MaxSegSize As Double
Dim MinSections As Integer
Dim NoOutPutAndDesignAtElementEnds As Boolean
Dim NoOutPutAndDesignAtPointLoads As Boolean
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4, 12, 12, 4, 4, 24, 24)
ret = SapModel.FrameObj.GetOutputStations("15", MyType, MaxSegSize, MinSections, NoOutPutAndDesignAtElementEnds, NoOutPutAndDesignAtPointLoads)
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
Public Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
Dim MyType As Integer
Dim MaxSegSize As Double
Dim MinSections As Integer
Dim NoOutPutAndDesignAtElementEnds As Boolean
Dim NoOutPutAndDesignAtPointLoads As Boolean
'create ETABS object
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
'start ETABS application
ret = EtabsObject.ApplicationStart()
'create SapModel object
SapModel = EtabsObject.SapModel
'initialize model
ret = SapModel.InitializeNewModel()
'create steel deck template model
ret = SapModel.File.NewSteelDeck(4, 12, 12, 4, 4, 24, 24)
'get frame output station data
ret = SapModel.FrameObj.GetOutputStations("15", MyType, MaxSegSize, MinSections, NoOutPutAndDesignAtElementEnds, NoOutPutAndDesignAtPointLoads)
'close ETABS
EtabsObject.ApplicationExit(False)
'clean up variables
SapModel = Nothing
EtabsObject = Nothing
End Sub