cDiaphragm SetDiaphragm Method CSi API ETABS 2015
Adds a new diaphragm, or modifies an existing diaphragm

Namespace: ETABS2015
Assembly: ETABS2015 (in ETABS2015.dll) Version: 15.0.0.0 (15.0.0.0)
Syntax

int SetDiaphragm(
	string Name,
	bool SemiRigid
)

Parameters

Name
Type: OnlineSystem String
This is the name of a diaphragm. If this is the name of an existing diaphragm, that diaphragm is modified, otherwise a new diaphragm is added.
SemiRigid
Type: OnlineSystem Boolean
This item is True if the diaphragm is to be semi-rigid, and False otherwise

Return Value

Returns zero if the diaphragm is successfully added or modified, otherwise it returns a nonzero value.
Remarks

Examples

See Also