cPropLink GetLinear Method CSi API ETABS 2015
Retrieves link property data for a linear-type link property.

Namespace: ETABS2015
Assembly: ETABS2015 (in ETABS2015.dll) Version: 15.0.0.0 (15.0.0.0)
Syntax

int GetLinear(
	string Name,
	ref bool[] DOF,
	ref bool[] Fixed,
	ref double[] Ke,
	ref double[] Ce,
	ref double DJ2,
	ref double DJ3,
	ref bool KeCoupled,
	ref bool CeCoupled,
	ref string Notes,
	ref string GUID
)

Parameters

Name
Type: OnlineSystem String
The name of an existing linear-type link property.
DOF
Type:  OnlineSystem Boolean  
Fixed
Type:  OnlineSystem Boolean  
This is a boolean array, dimensioned to 5, indicating if the specified degree of freedom is fixed (restrained).
ValueFixity
Fixed(0)U1 fixity if DOF(0) = True
Fixed(1)U2 fixity if DOF(1) = True
Fixed(2)U3 fixity if DOF(2) = True
Fixed(3)R1 fixity if DOF(3) = True
Fixed(4)R2 fixity if DOF(4) = True
Fixed(5)R3 fixity if DOF(5) = True
Ke
Type:  OnlineSystem Double  
Ce
Type:  OnlineSystem Double  
DJ2
Type: OnlineSystem Double 
DJ3
Type: OnlineSystem Double 
KeCoupled
Type: OnlineSystem Boolean 
This item is True if the link stiffness, Ke, is coupled. There are 21 terms in the Ke array if Ke is coupled; otherwise there are 6 terms
CeCoupled
Type: OnlineSystem Boolean 
This item is True if the link damping, Ce, is coupled. There are 21 terms in the Ce array if Ce is coupled; otherwise there are 6 terms
Notes
Type: OnlineSystem String 
GUID
Type: OnlineSystem String 
The GUID (global unique identifier), if any, assigned to the property.

Return Value

Returns zero if the property data is successfully retrieved; otherwise it returns a nonzero value.
Remarks

Examples

See Also