Returns the total number of defined link properties in the model.
If desired, counts can be returned for all link properties of a specified type in the model.
Namespace: ETABS2015Assembly: ETABS2015 (in ETABS2015.dll) Version: 15.0.0.0 (15.0.0.0)
int Count(
eLinkPropType PropType =
)
Function Count ( _
Optional PropType As eLinkPropType = _
) As Integer
int Count(
eLinkPropType PropType =
)
Parameters
- PropType (Optional)
- Type: ETABS2015 eLinkPropType
This optional value is one of the items in the
eLinkPropType enumeration. If no value is input for PropType,
a count is returned for all link properties in the model regardless of type.
Return Value
Returns the total number of defined link properties in the model.
Public Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
Dim DOF() As Boolean
Dim Fixed() As Boolean
Dim Ke() As Double
Dim Ce() As Double
Dim Count As Integer
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)
ReDim DOF(5)
ReDim Fixed(5)
ReDim Ke(5)
ReDim Ce(5)
DOF(0) = True
Ke(0) = 12
ret = SapModel.PropLink.SetLinear("L1", DOF, Fixed, Ke, Ce, 0, 0)
Count = SapModel.PropLink.Count
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
Public Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
Dim DOF() As Boolean
Dim Fixed() As Boolean
Dim Ke() As Double
Dim Ce() As Double
Dim Count As Integer
'create ETABS object
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
'start ETABS application
ret = EtabsObject.ApplicationStart()
'create SapModel object
SapModel = EtabsObject.SapModel
'initialize model
ret = SapModel.InitializeNewModel()
'create steel deck template model
ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)
'add link property
ReDim DOF(5)
ReDim Fixed(5)
ReDim Ke(5)
ReDim Ce(5)
DOF(0) = True
Ke(0) = 12
ret = SapModel.PropLink.SetLinear("L1", DOF, Fixed, Ke, Ce, 0, 0)
'return number of defined links of all types
Count = SapModel.PropLink.Count
'close ETABS
EtabsObject.ApplicationExit(False)
'clean up variables
SapModel = Nothing
EtabsObject = Nothing
End Sub