cPropMaterial GetMassSource Method CSi API ETABS 2015
DEPRECATED Retrieves the mass source for the model.

Namespace: ETABS2015
Assembly: ETABS2015 (in ETABS2015.dll) Version: 15.0.0.0 (15.0.0.0)
Syntax

int GetMassSource(
	ref int MyOption,
	ref int NumberLoads,
	ref string[] LoadPat,
	ref double[] SF
)

Parameters

MyOption
Type: OnlineSystem Int32 
This is 1, 2 or 3, indicating the mass source option.
ValueOption
1From element self mass and additional masses
2From loads
3From element self mass and additional masses and loads
NumberLoads
Type: OnlineSystem Int32 
The number of load patterns from which mass is obtained. This item applies only when MyOption is 2 or 3.
LoadPat
Type:  OnlineSystem String  
This is an array of the names of the load patterns from which mass is obtained. This item applies only when MyOption is 2 or 3.
SF
Type:  OnlineSystem Double  

Return Value

Returns zero if the mass source is successfully retrieved; otherwise it returns a nonzero value.
Remarks

This function is DEPRECATED. Please use GetMassSource_1(Boolean , Boolean , Boolean , Int32 ,  String  ,  Double  )
Examples

See Also