cCombo GetCaseList Method CSi API ETABS 2015
Retrieves all load cases and response combinations included in the load combination specified by the Name item.

Namespace: ETABS2015
Assembly: ETABS2015 (in ETABS2015.dll) Version: 15.0.0.0 (15.0.0.0)
Syntax

int GetCaseList(
	string Name,
	ref int NumberItems,
	ref eCNameType[] CNameType,
	ref string[] CName,
	ref double[] SF
)

Parameters

Name
Type: OnlineSystem String
The name of an existing load combination.
NumberItems
Type: OnlineSystem Int32 
The total number of load cases and load combinations included in the load combination specified by the Name item.
CNameType
Type:  ETABS2015 eCNameType  
This is one of the following items in the eCNameType enumeration:
  • LoadCase = 0
  • LoadCombo = 1

This item indicates whether the CName item is an analysis case (LoadCase) or a load combination (LoadCombo).

CName
Type:  OnlineSystem String  
This is an array of the names of the load cases or load combinations included in the load combination specified by the Name item.
SF
Type:  OnlineSystem Double  

Return Value

Returns zero if the data is successfully retrieved, otherwise it returns a nonzero value.
Remarks

Examples

See Also