Defines a tendon property
Namespace: ETABS2015Assembly: ETABS2015 (in ETABS2015.dll) Version: 15.0.0.0 (15.0.0.0)
int SetProp(
string Name,
string MatProp,
int ModelingOption,
double Area,
int Color = -1,
string Notes = "",
string GUID = ""
)
Function SetProp ( _
Name As String, _
MatProp As String, _
ModelingOption As Integer, _
Area As Double, _
Optional Color As Integer = -1, _
Optional Notes As String = "", _
Optional GUID As String = "" _
) As Integer
int SetProp(
String^ Name,
String^ MatProp,
int ModelingOption,
double Area,
int Color = -1,
String^ Notes = L"",
String^ GUID = L""
)
Parameters
- Name
- Type:
System String
The name of an existing or new tendon property.
If this is an existing property, that property is modified; otherwise, a new property is added.
- MatProp
- Type:
System String
The name of the material property assigned to the tendon property.
- ModelingOption
- Type:
System Int32
This is either 1 or 2, indicating the tendon modeling option.
Value | Modeling Option |
---|
1 | Model tendon as loads |
2 | Model tendon as elements |
- Area
- Type:
System Double
The cross-sectional area of the tendon. [L2]
- Color (Optional)
- Type:
System Int32
- Notes (Optional)
- Type:
System String
- GUID (Optional)
- Type:
System String
The GUID (global unique identifier), if any, assigned to the property.
If this item is input as Default, the program assigns a GUID to the property
Return Value
Returns zero if the property is successfully defined; otherwise it returns a nonzero value.
Modeling tendons as elements (
ModelingOption = 2) is not supported in ETABS.
Public Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
Dim Name As String
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)
ret = SapModel.PropMaterial.AddQuick(Name, ETABS2013.eMatType.Tendon, , , , , , ETABS2013.eMatTypeTendon.ASTM_A416Gr270)
ret = SapModel.PropTendon.SetProp("T1", Name, 1, 2.25)
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
Public Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
Dim Name As String
'create ETABS object
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
'start ETABS application
ret = EtabsObject.ApplicationStart()
'create SapModel object
SapModel = EtabsObject.SapModel
'initialize model
ret = SapModel.InitializeNewModel()
'create steel deck template model
ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)
'add tendon material
ret = SapModel.PropMaterial.AddQuick(Name, ETABS2013.eMatType.Tendon, , , , , , ETABS2013.eMatTypeTendon.ASTM_A416Gr270)
'set new tendon property
ret = SapModel.PropTendon.SetProp("T1", Name, 1, 2.25)
'close ETABS
EtabsObject.ApplicationExit(False)
'clean up variables
SapModel = Nothing
EtabsObject = Nothing
End Sub