cPropLink SetFrictionIsolator Method CSi API ETABS 2015
Initializes a friction isolator-type link property. If this function is called for an existing link property, all items for the property are reset to their default value.

Namespace: ETABS2015
Assembly: ETABS2015 (in ETABS2015.dll) Version: 15.0.0.0 (15.0.0.0)
Syntax

int SetFrictionIsolator(
	string Name,
	ref bool[] DOF,
	ref bool[] Fixed,
	ref bool[] Nonlinear,
	ref double[] Ke,
	ref double[] Ce,
	ref double[] K,
	ref double[] Slow,
	ref double[] Fast,
	ref double[] Rate,
	ref double[] Radius,
	double Damping,
	double DJ2,
	double DJ3,
	string Notes = "",
	string GUID = ""
)

Parameters

Name
Type: OnlineSystem String
The name of an existing or new link property. If this is an existing property, that property is modified; otherwise, a new property is added
DOF
Type:  OnlineSystem Boolean  
Fixed
Type:  OnlineSystem Boolean  
This is a boolean array, dimensioned to 5, indicating if the specified degree of freedom is fixed (restrained).
ValueFixity
Fixed(0)U1 fixity if DOF(0) = True
Fixed(1)U2 fixity if DOF(1) = True
Fixed(2)U3 fixity if DOF(2) = True
Fixed(3)R1 fixity if DOF(3) = True
Fixed(4)R2 fixity if DOF(4) = True
Fixed(5)R3 fixity if DOF(5) = True
Nonlinear
Type:  OnlineSystem Boolean  
This is a boolean array, dimensioned to 5, indicating if nonlinear properties exist for a specified degree of freedom.
ValueNonlinear
Nonlinear(0)U1 has nonlinear properties
Nonlinear(1)U2 has nonlinear properties
Nonlinear(2)U3 has nonlinear properties
Nonlinear(3)R1, not used
Nonlinear(4)R2, not used
Nonlinear(5)R3, not used

Note that this item is applicable only for degrees of freedom U1, U2 and U3. For those degrees of freedom, the term Nonlinear(n) applies only when DOF(n) = True and Fixed(n) = False.

Ke
Type:  OnlineSystem Double  
Ce
Type:  OnlineSystem Double  
K
Type:  OnlineSystem Double  
Slow
Type:  OnlineSystem Double  
This is an array of the friction coefficient at zero velocity terms for the link property. This coefficient applies for nonlinear analyses.
ValueSlow
Slow(0)U1, not used
Slow(1)U2
Slow(2)U3
Slow(3)R1, not used
Slow(4)R2, not used
Slow(5)R3, not used

Note that this item is applicable only for degrees of freedom U2 and U3. For those degrees of freedom, the term Slow(n) applies only when DOF(n) = True, Fixed(n) = False, and Nonlinear(n) = True.

Fast
Type:  OnlineSystem Double  
This is an array of the friction coefficient at fast velocity terms for the link property. This coefficient applies for nonlinear analyses.
ValueFast
Fast(0)U1, not used
Fast(1)U2
Fast(2)U3
Fast(3)R1, not used
Fast(4)R2, not used
Fast(5)R3, not used

Note that this item is applicable only for degrees of freedom U2 and U3. For those degrees of freedom, the term Fast(n) applies only when DOF(n) = True, Fixed(n) = False, and Nonlinear(n) = True.

Rate
Type:  OnlineSystem Double  
This is an array of the inverse of the characteristic sliding velocity terms for the link property. This item applies for nonlinear analyses.
ValueRate
Rate(0)U1, not used
Rate(1)U2 [s/L]
Rate(2)U3 [s/L]
Rate(3)R1, not used
Rate(4)R2, not used
Rate(5)R3, not used

Note that this item is applicable only for degrees of freedom U2 and U3. For those degrees of freedom, the term Fast(n) applies only when DOF(n) = True, Fixed(n) = False, and Nonlinear(n) = True.

Radius
Type:  OnlineSystem Double  
This is an array of the radius of the sliding contact surface terms for the link property. Inputting 0 means there is an infinite radius, that is, the slider is flat. This item applies for nonlinear analyses.
ValueRadius
Radius(0)U1, not used
Radius(1)U2 [L]
Radius(2)U3 [L]
Radius(3)R1, not used
Radius(4)R2, not used
Radius(5)R3, not used

Note that this item is applicable only for degrees of freedom U2 and U3. For those degrees of freedom, the term Fast(n) applies only when DOF(n) = True, Fixed(n) = False, and Nonlinear(n) = True.

Damping
Type: OnlineSystem Double
DJ2
Type: OnlineSystem Double
DJ3
Type: OnlineSystem Double
Notes (Optional)
Type: OnlineSystem String
GUID (Optional)
Type: OnlineSystem String
The GUID (global unique identifier), if any, assigned to the property. If this item is input as Default, the program assigns a GUID to the property.

Return Value

Returns zero if the property is successfully initialized; otherwise it returns a nonzero value.
Remarks

Examples

See Also