Adds/removes link objects to/from a specified group.
Namespace: ETABS2015Assembly: ETABS2015 (in ETABS2015.dll) Version: 15.0.0.0 (15.0.0.0)
int SetGroupAssign(
string Name,
string GroupName,
bool Remove = false,
eItemType ItemType = eItemType.Objects
)
Function SetGroupAssign ( _
Name As String, _
GroupName As String, _
Optional Remove As Boolean = False, _
Optional ItemType As eItemType = eItemType.Objects _
) As Integer
int SetGroupAssign(
String^ Name,
String^ GroupName,
bool Remove = false,
eItemType ItemType = eItemType::Objects
)
Parameters
- Name
- Type:
System String
The name of an existing link object or group, depending on the value of the
ItemType item.
- GroupName
- Type:
System String
The name of an existing group to which the assignment is made.
- Remove (Optional)
- Type:
System Boolean
- ItemType (Optional)
- Type: ETABS2015 eItemType
This is one of the items in the eItemType enumeration.
If this item is Objects, the link object specified by
the Name item is added/removed to/from the group specified by
the GroupName item.
If this item is Group, the link objects in the group specified by
the Name item is added/removed to/from the group specified by
the GroupName item.
If this item is SelectedObjects, all selected link objects are
added/removed to/from the group specified by the GroupName item,
and the Name item is ignored.
Return Value
Returns zero if the group assignment is successful;
otherwise it returns a nonzero value.
Public Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
Dim Name As String
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)
ret = SapModel.LinkObj.AddByPoint("1", "5", Name)
ret = SapModel.GroupDef.SetGroup("Group1")
ret = SapModel.LinkObj.SetGroupAssign(Name, "Group1")
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
Public Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
Dim Name As String
'create ETABS object
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
'start ETABS application
ret = EtabsObject.ApplicationStart()
'create SapModel object
SapModel = EtabsObject.SapModel
'initialize model
ret = SapModel.InitializeNewModel()
'create steel deck template model
ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)
'add link object by points
ret = SapModel.LinkObj.AddByPoint("1", "5", Name)
'define new group
ret = SapModel.GroupDef.SetGroup("Group1")
'add link object to group
ret = SapModel.LinkObj.SetGroupAssign(Name, "Group1")
'close ETABS
EtabsObject.ApplicationExit(False)
'clean up variables
SapModel = Nothing
EtabsObject = Nothing
End Sub