cAreaObj GetLoadWindPressure Method CSi API ETABS 2015
Retrieves the wind pressure load assignments to area objects.

Namespace: ETABS2015
Assembly: ETABS2015 (in ETABS2015.dll) Version: 15.0.0.0 (15.0.0.0)
Syntax

int GetLoadWindPressure(
	string Name,
	ref int NumberItems,
	ref string[] AreaName,
	ref string[] LoadPat,
	ref int[] MyType,
	ref double[] Cp,
	eItemType ItemType = eItemType.Objects
)

Parameters

Name
Type: OnlineSystem String
The name of an existing area object or group, depending on the value of the ItemType item.
NumberItems
Type: OnlineSystem Int32 
The total number of wind pressure loads retrieved for the specified area objects.
AreaName
Type:  OnlineSystem String  
This is an array that includes the name of the area object associated with each wind pressure load.
LoadPat
Type:  OnlineSystem String  
This is an array that includes the name of the load pattern associated with each wind pressure load.
MyType
Type:  OnlineSystem Int32  
This is an array that includes either 1 or 2, indicating the wind pressure type.
  1. Windward, pressure varies over height
  2. Other, pressure is constant over height
Cp
Type:  OnlineSystem Double  
This is an array that includes the wind pressure coefficient value.
ItemType (Optional)
Type: ETABS2015 eItemType
This is one of the following items in the eItemType enumeration:
  • Object = 0
  • Group = 1
  • SelectedObjects = 2

If this item is Objects, the assignments are retrieved for the area object specified by the Name item.

If this item is Group, the assignments are retrieved for all area objects in the group specified by the Name item.

If this item is SelectedObjects, assignments are retrieved for is made to all selected area objects, and the Name item is ignored.

Return Value

Returns zero if the load assignments are successfully retrieved; it returns a nonzero value.
Remarks

See Also