cSapModel Results Property CSi API ETABS 2015
Gives access to API calls related to analysis results.

Namespace: ETABS2015
Assembly: ETABS2015 (in ETABS2015.dll) Version: 15.0.0.0 (15.0.0.0)
Syntax

cAnalysisResults Results { get; }

Field Value

Return Value

Remarks

The analysis results are returned in a collection of one-dimensional result arrays. Each result array is created as a dynamic array by the API user. As an example, in VB .NET a dynamic string array is defined by:

The array is dimensioned to (NumberResults– 1) inside the program, filled with the result values, and returned to the API user.

The arrays are zero-based. Thus the first result is at array index 0, and the last result is at array index (NumberResults- 1). For example, the StepType() array is filled as:

Immediately before requesting results data, it is a good idea to clear the SelectedForOutput flag for all load cases and response combinations and then to set the flag True for those cases and combos for which output is to be generated. This avoids confusion as to which cases and combos are currently selected for output.

See Also