retrieves link property data for a multilinear elastic-type link property.
Namespace: ETABS2015Assembly: ETABS2015 (in ETABS2015.dll) Version: 15.0.0.0 (15.0.0.0)
Syntax
Parameters
- Name
- Type:
System String
The name of an existing damper-type link property.
- DOF
- Type:
System Boolean
- Fixed
- Type:
System Boolean
This is a boolean array, dimensioned to 5, indicating if the specified degree of freedom is fixed (restrained).Value Fixity Fixed(0) U1 fixity if DOF(0) = True Fixed(1) U2 fixity if DOF(1) = True Fixed(2) U3 fixity if DOF(2) = True Fixed(3) R1 fixity if DOF(3) = True Fixed(4) R2 fixity if DOF(4) = True Fixed(5) R3 fixity if DOF(5) = True The term Fixed(n) applies only when DOF(n) = True.
- Nonlinear
- Type:
System Boolean
This is a boolean array, dimensioned to 5, indicating if nonlinear properties exist for a specified degree of freedom.Value Nonlinear Nonlinear(0) U1 has nonlinear properties Nonlinear(1) U2 has nonlinear properties Nonlinear(2) U3 has nonlinear properties Nonlinear(3) R1 has nonlinear properties Nonlinear(4) R2 has nonlinear properties Nonlinear(5) R3 has nonlinear properties The term Nonlinear(n) applies only when DOF(n) = True and Fixed(n) = False.
- Ke
- Type:
System Double
- Ce
- Type:
System Double
- DJ2
- Type:
System Double
- DJ3
- Type:
System Double
- Notes
- Type:
System String
- GUID
- Type:
System String
The GUID (global unique identifier), if any, assigned to the property.
Return Value
Returns zero if the property is successfully retrieved; otherwise it returns a nonzero value.Remarks
Examples
See Also