cDetailingGetBeamTieRebarData Method |
Retrieves tie (confinement/shear) rebar data for a beam frame object
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint GetBeamTieRebarData(
string Name,
ref int NumberRebarSets,
ref string[] BarSizeName,
ref double[] BarArea,
ref double[] NumberLegs,
ref string[] Location,
ref double[] ClearCover,
ref double[] StartCoord1,
ref double[] Spacing,
ref double[] Lengths,
ref string[] RebarSetGUID
)
Function GetBeamTieRebarData (
Name As String,
ByRef NumberRebarSets As Integer,
ByRef BarSizeName As String(),
ByRef BarArea As Double(),
ByRef NumberLegs As Double(),
ByRef Location As String(),
ByRef ClearCover As Double(),
ByRef StartCoord1 As Double(),
ByRef Spacing As Double(),
ByRef Lengths As Double(),
ByRef RebarSetGUID As String()
) As Integer
int GetBeamTieRebarData(
String^ Name,
int% NumberRebarSets,
array<String^>^% BarSizeName,
array<double>^% BarArea,
array<double>^% NumberLegs,
array<String^>^% Location,
array<double>^% ClearCover,
array<double>^% StartCoord1,
array<double>^% Spacing,
array<double>^% Lengths,
array<String^>^% RebarSetGUID
)
abstract GetBeamTieRebarData :
Name : string *
NumberRebarSets : int byref *
BarSizeName : string[] byref *
BarArea : float[] byref *
NumberLegs : float[] byref *
Location : string[] byref *
ClearCover : float[] byref *
StartCoord1 : float[] byref *
Spacing : float[] byref *
Lengths : float[] byref *
RebarSetGUID : string[] byref -> int
Parameters
- Name
- Type: SystemString
The name of an existing beam frame object - NumberRebarSets
- Type: SystemInt32
Number of tie rebar sets for this beam object - BarSizeName
- Type: SystemString
Rebar designation - BarArea
- Type: SystemDouble
Individual rebar area - NumberLegs
- Type: SystemDouble
Number of legs for ties in this set (legs are in the local 2 direction) - Location
- Type: SystemString
Zone of this set of rebars - A, B, C, etc. (See picture for seismic/ non-seismic detailing) - ClearCover
- Type: SystemDouble
Clear cover from beam face to ties being specified - StartCoord1
- Type: SystemDouble
Start of this set of tie rebars from start/end (depends on location) of beam object - Spacing
- Type: SystemDouble
Spacing of ties - Lengths
- Type: SystemDouble
Length over which these tie bars are provided from start point - RebarSetGUID
- Type: SystemString
The GUIDs of each of the rebar sets (could be duplicated for adjacent beam if rebars are continuous)
Return Value
Type:
Int32 Returns zero if the rebar data is successfully retrieved; otherwise it returns a nonzero value.
See Also