cAreaObjGetLoadTemperature Method |
Retrieves the temperature load assignments to area objects.
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint GetLoadTemperature(
string Name,
ref int NumberItems,
ref string[] AreaName,
ref string[] LoadPat,
ref int[] MyType,
ref double[] Value,
ref string[] PatternName,
eItemType ItemType = eItemType.Objects
)
Function GetLoadTemperature (
Name As String,
ByRef NumberItems As Integer,
ByRef AreaName As String(),
ByRef LoadPat As String(),
ByRef MyType As Integer(),
ByRef Value As Double(),
ByRef PatternName As String(),
Optional ItemType As eItemType = eItemType.Objects
) As Integer
int GetLoadTemperature(
String^ Name,
int% NumberItems,
array<String^>^% AreaName,
array<String^>^% LoadPat,
array<int>^% MyType,
array<double>^% Value,
array<String^>^% PatternName,
eItemType ItemType = eItemType::Objects
)
abstract GetLoadTemperature :
Name : string *
NumberItems : int byref *
AreaName : string[] byref *
LoadPat : string[] byref *
MyType : int[] byref *
Value : float[] byref *
PatternName : string[] byref *
?ItemType : eItemType
(* Defaults:
let _ItemType = defaultArg ItemType eItemType.Objects
*)
-> int
Parameters
- Name
- Type: SystemString
The name of an existing area object or group, depending on the value
of the ItemType item.
- NumberItems
- Type: SystemInt32
The total number of temperature loads retrieved for the specified area objects.
- AreaName
- Type: SystemString
This is an array that includes the name of the area object associated
with each temperature load.
- LoadPat
- Type: SystemString
This is an array that includes the name of the load pattern associated
with each temperature load.
- MyType
- Type: SystemInt32
This is an array that includes either 1 or 3, indicating
the type of temperature load.
- 1 = Temperature
- 3 = Temperature gradient along local 3 axis
- Value
- Type: SystemDouble
This is an array that includes the temperature load value.
[T] for MyType = 1 and
[T/L] for MyType= 3.
- PatternName
- Type: SystemString
This is an array that includes the joint pattern name, if any,
used to specify the temperature load.
- ItemType (Optional)
- Type: ETABS2016eItemType
This is one of the following items in the eItemType enumeration:
- Object = 0
- Group = 1
- SelectedObjects = 2
If this item is Objects, the assignments are retrieved
for the area object specified by the Name item.
If this item is Group, the assignments are retrieved
for all area objects in the group specified by the Name item.
If this item is SelectedObjects, assignments are retrieved
for is made to all selected area objects, and the Name item is ignored.
Return Value
Type:
Int32
Returns zero if the load assignments are successfully retrieved;
otherwise it returns a nonzero value.
Remarks
See Also