cPierLabelGetSectionProperties Method |
Retrieves the section properties for a specified pier.
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint GetSectionProperties(
string Name,
ref int NumberStories,
ref string[] StoryName,
ref double[] AxisAngle,
ref int[] NumAreaObjs,
ref int[] NumLineObjs,
ref double[] WidthBot,
ref double[] ThicknessBot,
ref double[] WidthTop,
ref double[] ThicknessTop,
ref string[] MatProp,
ref double[] CGBotX,
ref double[] CGBotY,
ref double[] CGBotZ,
ref double[] CGTopX,
ref double[] CGTopY,
ref double[] CGTopZ
)
Function GetSectionProperties (
Name As String,
ByRef NumberStories As Integer,
ByRef StoryName As String(),
ByRef AxisAngle As Double(),
ByRef NumAreaObjs As Integer(),
ByRef NumLineObjs As Integer(),
ByRef WidthBot As Double(),
ByRef ThicknessBot As Double(),
ByRef WidthTop As Double(),
ByRef ThicknessTop As Double(),
ByRef MatProp As String(),
ByRef CGBotX As Double(),
ByRef CGBotY As Double(),
ByRef CGBotZ As Double(),
ByRef CGTopX As Double(),
ByRef CGTopY As Double(),
ByRef CGTopZ As Double()
) As Integer
int GetSectionProperties(
String^ Name,
int% NumberStories,
array<String^>^% StoryName,
array<double>^% AxisAngle,
array<int>^% NumAreaObjs,
array<int>^% NumLineObjs,
array<double>^% WidthBot,
array<double>^% ThicknessBot,
array<double>^% WidthTop,
array<double>^% ThicknessTop,
array<String^>^% MatProp,
array<double>^% CGBotX,
array<double>^% CGBotY,
array<double>^% CGBotZ,
array<double>^% CGTopX,
array<double>^% CGTopY,
array<double>^% CGTopZ
)
abstract GetSectionProperties :
Name : string *
NumberStories : int byref *
StoryName : string[] byref *
AxisAngle : float[] byref *
NumAreaObjs : int[] byref *
NumLineObjs : int[] byref *
WidthBot : float[] byref *
ThicknessBot : float[] byref *
WidthTop : float[] byref *
ThicknessTop : float[] byref *
MatProp : string[] byref *
CGBotX : float[] byref *
CGBotY : float[] byref *
CGBotZ : float[] byref *
CGTopX : float[] byref *
CGTopY : float[] byref *
CGTopZ : float[] byref -> int
Parameters
- Name
- Type: SystemString
The name of an existing pier. - NumberStories
- Type: SystemInt32
The number of stories that the pier exists on and for which section properties are provided. - StoryName
- Type: SystemString
This is an array that includes the story names at which the pier exists. - AxisAngle
- Type: SystemDouble
This is an array that includes the pier local axis angle at each story, defined as the angle between the global x-axis and the pier local 2-axis. - NumAreaObjs
- Type: SystemInt32
This is an array that includes the number of area objects in the pier at each story. - NumLineObjs
- Type: SystemInt32
This is an array that includes the number of line objects in the pier at each story. - WidthBot
- Type: SystemDouble
This is an array that includes the width of the pier at the bottom of each story. - ThicknessBot
- Type: SystemDouble
This is an array that includes the thickness of the pier at the bottom of each story. - WidthTop
- Type: SystemDouble
This is an array that includes the width of the pier at the top of each story. - ThicknessTop
- Type: SystemDouble
This is an array that includes the thickness of the pier at the top of each story. - MatProp
- Type: SystemString
This is an array that includes the name of the pier material property at each story. - CGBotX
- Type: SystemDouble
This is an array that includes the x-coordinate of the pier center of gravity at the bottom of each story. - CGBotY
- Type: SystemDouble
This is an array that includes the y-coordinate of the pier center of gravity at the bottom of each story. - CGBotZ
- Type: SystemDouble
This is an array that includes the z-coordinate of the pier center of gravity at the bottom of each story. - CGTopX
- Type: SystemDouble
This is an array that includes the x-coordinate of the pier center of gravity at the top of each story. - CGTopY
- Type: SystemDouble
This is an array that includes the y-coordinate of the pier center of gravity at the top of each story. - CGTopZ
- Type: SystemDouble
This is an array that includes the z-coordinate of the pier center of gravity at the top of each story.
Return Value
Type:
Int32Returns zero if the data is successfully retrieved; otherwise it returns a nonzero value.
Remarks
See Also